9.0beta4announcement

From PostgreSQL wiki

Revision as of 07:56, 23 September 2010 by Itagaki (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

The fourth beta release for PostgreSQL version 9.0 is now available. This beta contains numerous fixes and a few changes since beta3. As this is likely to be the last beta release, please download, install, and test it so that we can move toward final release of 9.0.

Beta4 contains primarily bug-fixes in response to user testing reports since Beta3. The one significant user-facing change is to report \timing information even when psql is being run in "quiet" mode. Fixes include:

  • Report disk space error properly and do not load .psqlrc when using pg_upgrade;
  • Allow full SSL certificate verification when host and hostaddr are both specified, backpatched to 8.4;
  • Fix for pg_dump's handling of SQL/MED objects;
  • Bugfix and performance improvement for scans of lossy GIN index pointers;
  • Fix for possible page corruption in ALTER TABLE .. SET TABLESPACE;
  • Properly replay CREATE TABLESPACE during crash recovery;
  • Cleanup subtransactions in FOR loops, and avoid deep recursion when assigning XIDs to multiple levels of subtransactions, both backpatched to 8.0.

Unlike previous betas, there has been no system catalog change since Beta3, so an initdb should not be required to upgrade test databases from Beta3. Upgrading test databases from earlier versions or betas will require an initdb, however, so we urge users to take the opportunity to test upgrading their database using 9.0's pg_upgrade and report the results.

If you are able to help with beta testing, please see the Beta testing page.

Betas are not stable and should never be used in production; they are for testing only. A release candidate will be available for testing soon.

Source code, as well as binary installers for many platforms, is available from the PostgreSQL Web Site:

Personal tools